Home
Results 1 to 10 of 10

Thread: Xenon not working...

  1. #1
    byRazh's Avatar
    Join Date
    Mar 2019
    Posts
    5
    Thanked 0 Times in 0 Posts

    Default Xenon not working...

    Hello!

    My xenon bulb stopped working so I replaced it with a brand new one but still not working... What could be the problem?

    Thanks in advance!

  2. #2
    mike.h's Avatar
    Join Date
    Oct 2016
    Location
    Horsham, West Sussex
    Posts
    1,642
    Thanked 396 Times in 322 Posts

    Default

    Ballast, cables, fuses, connections in general?

    Which car? 3rd party install I guess?
    Subaru Leone | EF Hatch | EG4 VTi | Rover 214Si | EK | BB5 | EP3 | EP3

  3. #3
    byRazh's Avatar
    Join Date
    Mar 2019
    Posts
    5
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by mike.h View Post
    Ballast, cables, fuses, connections in general?

    Which car? 3rd party install I guess?
    Its a EP3. The previous owner changed the thing the bulb sits in and its not an oem part. Could it possibly be something wrong with that part?

    Ive checked the fuses and all look fine.
    Last edited by byRazh; 17-05-2019 at 04:15 PM.

  4. #4
    mike.h's Avatar
    Join Date
    Oct 2016
    Location
    Horsham, West Sussex
    Posts
    1,642
    Thanked 396 Times in 322 Posts

    Default

    If the bulb is fine and the fuses are okay, the likely culprit is the ballast/exciter. A lot of people buy cheap, this is the sad outcome.
    Subaru Leone | EF Hatch | EG4 VTi | Rover 214Si | EK | BB5 | EP3 | EP3

  5. #5
    byRazh's Avatar
    Join Date
    Mar 2019
    Posts
    5
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by mike.h View Post
    If the bulb is fine and the fuses are okay, the likely culprit is the ballast/exciter. A lot of people buy cheap, this is the sad outcome.
    A new ballast is around 400 and I dont feel like spending that much just to get a bulb working haha. Maybe a second hand oem one is better than a new cheap one?

  6. #6
    Site Treasurer Loxy's Avatar
    Join Date
    Jan 2009
    Location
    Lancs
    Posts
    28,982
    Thanked 7,900 Times in 5,517 Posts

    Default

    If it's an aftermarket kit, a ballast won't be that much.

    Have you any pics of the kit?

  7. #7
    byRazh's Avatar
    Join Date
    Mar 2019
    Posts
    5
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by Loxy View Post
    If it's an aftermarket kit, a ballast won't be that much.

    Have you any pics of the kit?
    Im going to try to get some pictures today. If it is the ballast that is broken, what should I look for when buying a new one?

  8. #8
    byRazh's Avatar
    Join Date
    Mar 2019
    Posts
    5
    Thanked 0 Times in 0 Posts

    Default

    Quote Originally Posted by Loxy View Post
    If it's an aftermarket kit, a ballast won't be that much.

    Have you any pics of the kit?
    Didn't manage to get far but got these pics. This is the part the previous owner changed to an aftermarket part (not OEM). Do I need to take the front bumper off to remove this cable?

    Pictures: https://imgur.com/a/dbHmtM2

  9. #9
    mike.h's Avatar
    Join Date
    Oct 2016
    Location
    Horsham, West Sussex
    Posts
    1,642
    Thanked 396 Times in 322 Posts

    Default

    That looks like one of these - https://xenons4u.co.uk/mitsubishi-el...lb-holder.html

    WHich I guess means the ballast will be wherever the bottom end of that cable plugs into, and something like http://xenonland.com/product/1291/xe...2003-2010.html
    Last edited by mike.h; 18-05-2019 at 07:57 PM.
    Subaru Leone | EF Hatch | EG4 VTi | Rover 214Si | EK | BB5 | EP3 | EP3

  10. #10
    Tanny's Avatar
    Join Date
    Apr 2019
    Location
    Lancashire
    Posts
    94
    Thanked 8 Times in 8 Posts

    Default

    You could replace your whole Xenon / HID kit with a new one for not much money. Sometimes better to do this than spend money on used ballasts.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •