Home
Results 1 to 4 of 4

Thread: Type R FN2 - Electrics or LCD at fault?

  1. #1
    macleod2024's Avatar
    Join Date
    Jan 2020
    Posts
    5
    Thanked 1 Time in 1 Post

    Default Type R FN2 - Electrics or LCD at fault?

    I have an FN2 thatís had this fault since Iíve owned it. Itís never bothered me before but Iíve just had the Aircon serviced and regassed which means it now works and I donít want the A/C on all the time.

    I know that there can be problems with the LCD time/radio display. Now mine it doesnít go unreadable. What it does is flick off and on usually with bumps. Sometimes itís super sensitive, sometimes itíll just stay off. This is slightly different to what others have had so I wanted to know if anyone else had these symptoms and if it turned out to be the lcd?

    The only other thing that makes me wonder if itís solely the lcd is sometimes the stereo backlights arenít always on, though just to be clear they donít flicker off and on with the lcd. Also some times if I push the stereo upwards slightly that will bring the lcd back but I guess thatís because Iím pushing up on the whole unit.

    Any advice would be appreciated.
    Last edited by macleod2024; 24-12-2020 at 11:44 PM.

  2. #2
    Site Treasurer Loxy's Avatar
    Join Date
    Jan 2009
    Location
    Lancs
    Posts
    29,163
    Thanked 8,093 Times in 5,628 Posts

    Default

    Those LCD units are renowned for dry joints. If you're handy with an iron, refresh all of the solder and it usually sorts it out.

  3. #3
    macleod2024's Avatar
    Join Date
    Jan 2020
    Posts
    5
    Thanked 1 Time in 1 Post

    Default

    Thank you, so from that I take it you think that it’s definitely the lcd unit as well?
    I know they’re renowned for dodgy soldering. I wanted to double check the symptoms before taking it all apart etc.

  4. #4
    Site Treasurer Loxy's Avatar
    Join Date
    Jan 2009
    Location
    Lancs
    Posts
    29,163
    Thanked 8,093 Times in 5,628 Posts

    Default

    The LCD unit will likely be at fault, though since you say the lights on the headunit don't match the intermittent screen, you've likely got two faults that have occurred around the same time.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •