EML flashing

Messages
1,156
Drove the ep3 yesterday vtec in 1st gear and the EML started flashing for 5 seconds wonder what happened there?
 
Messages
1,792
I guess it could be damage to (or poor connection, or simply the age of) the coilpacks, it's a hard one to test though :(
 
Messages
173
Same as Chris, has it been mapped and the EML is acting as a shift light? I'd try get a code reader plugged in to see if any codes are there.
 
Last edited by a moderator:

Loxy

Site Treasurer
Staff member
Administrator
Messages
29,205
EML came on today P0325 Knock sensor bank 1
Is this related to the chain?
No, it's your knock sensor detecting knock otherwise known as detonation. Sometimes it's a faulty sensor, or it could be knock.
 
Messages
1,156
No, it's your knock sensor detecting knock otherwise known as detonation. Sometimes it's a faulty sensor, or it could be knock.
I did compression test all 4 cylinders show 180ish
I'm not sure what could it be,does it need valve clearance doing?
 

Loxy

Site Treasurer
Staff member
Administrator
Messages
29,205
I did compression test all 4 cylinders show 180ish
I'm not sure what could it be,does it need valve clearance doing?
Knock is pre-detonation which could be lots of things. Usually on a k20 it's timing, or fuel, but more often than not a faulty sensor.

Piston rings would be rare, but you've tested that.
 
Messages
1,156
Knock sensor arrived today,so I put the car on ramps and gone underneath to see and removed the bracket the supports the IM,remove the 2 bolts get to the sensor was knacked broken stuck,managed to get it off,replaced it with new one engine light is off.
 
Messages
1,156
:mad: Just can not believe it,the EML has come back on today,cylinder 3 is misfiring and all other are random misfire.
what is the cause now?
 

Loxy

Site Treasurer
Staff member
Administrator
Messages
29,205
Different fault codes, so you're starting again now. As always, internet diagnosis is always only that, one person who has never seen the car telling you what it could be.

Misfire is a problem with either fuel, air or compression. Since you've had the inlet manifold off, is it sealed back on properly, did you mess with the throttle body or IAT sensor?

The plugs were recently replaced? What happens if you swap the coil pack from 3 to 2 for example (edit:not sure if the cables are fixed to the coil packs, if so, difficult to test).

What condition are the injectors in? Does the fail follow the injector if you swap it from 3 to 2 for example. Last time I had a misfire it was a faulty injector.

When were the valve clearances last done? Has the timing been checked?

The list can go on really.

You've mentioned chain and compression test above, what has made you jump to those in your comments above. What's the mileage. What aren't you telling us. :)
 
Top